Razer Synapse 3 Connection

Started by chaosrain
Da8349b1b89be644f6d38c4c177ad178?s=128&d=mm

chaosrain

I recently received a set of Nanoleaf Shapes (Triangles). I have been able to successfully connect them to either an Android app or an iOS app and have even been able to get the Nanoleaf Windows app to work.

I cannot, however, get Razer's Synapse 3 to work with my Shapes at all. I have downloaded the Nanoleaf Pairing Tool (1.0.1.0) but it simply cannot find my Nanoleaf despite assigning a Static IP Address to the Nanoleaf. Same goes for the Nanoleaf app within Synapse 3. It cannot find the Nanoleaf on my network for pairing purposes.

This device was listed as Razer Chroma compatible, but is not working at all. Any suggestions or tricks that might help me out?

2527d9caa1edaf800ea810f658420e67?s=128&d=mm

imsodrink

I just encountered this problem with the Canvas panels. This might be a runaround solution but I deleted the nanoleaf module from synapse, turned off my Canvas, restarted my PC, downloaded the Canvas module again and as the module began "searching" mode it had already found my Canvas before I could enter "pairing" mode. It then asked me to go into "pairing" mode and I did so.

It worked from then on.

Da8349b1b89be644f6d38c4c177ad178?s=128&d=mm

chaosrain

Yeah…got an email from Nanoleaf. Apparently, their Shapes line will not be supported by Razer until some time in Q1 of 2021. So, while everyone has had issues with pairing with Nanoleaf in the past, my issues are the result of having bought too early. Gotta wait and hope…

A4803bca9fca211ede1b98a6361100e4?s=128&d=mm

black__wildflower__525

Same . I thought im the only one having the same issue .I have Hexagon and I tried everything i could . But the pairing with nanoleaf just made my synapse crashed .I tried like 20x . LOL

C4794ab95f854eed23aaf9db1e0b4610?s=128&d=mm

RaiNfire

Hi same problem here, just bought nanoleaf product (shapes) because of razer compatibility and got stuck, impossible to detect them. Please developers team, fix this, it would be very appreciated. (pairing tools look working only with aurora products.)

7d68db322966a4596b5c4a56e72feae8?s=128&d=mm

Evostance

If you have multiple network interfaces on your pc (wireless, Bluetooth, ethernet etc) then you need to go into the ipv4 properties of the one you are using, and change the priority of that connection to 1.

This will force everything to use that interface first, then your nanoleafs will show up

A4803bca9fca211ede1b98a6361100e4?s=128&d=mm

black__wildflower__525

@Evostance are you using Hexagon ?because I tried everything ,my hexagon is detected in synapse but it wont finish pairing(STUCK,i tried leaving it for hours) even tried connecting my PC using wifi to same wifi connection with hexagon .Tried ethernet .SAME cant seems to pair successfully .

7d68db322966a4596b5c4a56e72feae8?s=128&d=mm

Evostance

@black__wildflower__525 Yep, I'm using Hexagons. I can't actually get Synapse working because Razer want me to plugin a Razer product first, however by doing the above, I got the Shapes to show up in the Nanoleaf Extension

Da8349b1b89be644f6d38c4c177ad178?s=128&d=mm

chaosrain

Here we are nearly five months later. I would find it funny if it were not so sad that a few weeks ago someone from Nanoleaf posted to Reddit asking what fun features we'd like to see in upcoming Nanoleaf products. It's starting to look like they built a Razer Synapse 3 pairing tool for the Panels, then released the Shapes line as an "upgrade" but didn't write any code for them. I suspect Nanoleaf is moving on to their Homekit enabled essentials and leaving these products behind. They've been utterly silent on anything Shapes-related.