Nanoleaf Canvas not responding

Started by kingja3


I received my Nanoleaf Canvas 2 weeks ago and can't get them to work reliably with HomeKit. The Nanoleaf Light Panels I have installed next to it works perfectly.

Most of the time when I try to activate a scene using Home or the Nanoleaf app the connection will fail. I've already received a replacement control unit that displays the same issues.

Also i've bought a second Nanoleaf Canvas Starter Kit to try and it has the same problems.

What I've already tried:

  • My friends wifi network (and different homekit setup)
  • Factory resetting a couple of times
  • Changing all kinds of wifi/network settings (power, bandwidth, dhcp range, basically everything I could think of on the wifi side). I'm using a Unifi wifi network.

Does anyone of you recognize these problems with the Nanoleaf Canvas or maybe have some kind of solution? I suspect this is a software issue but i do now know if any update is incoming.

Marre NL

I have same issue. Only workaround is to reboot Canvas but this helps just for a short period of time and then this issue is back. It seems that Canvas freeze, so I don't think that it is only related to wifi or HomeKit. Try to disable scene sync, it make Canvas little more reliable too.


I'm in contact with the Nanoleaf team to further investigate this matter.

For now I found that when only using Basic/Static Colors scenes the problem disappears.

Marre NL

Yeah, on iOS even on latest firmware beta for Canvas I still have issues with no response or network errors. Resetting Canvas dosen't change too much and rebooting helps just for short period of time. I think this is right now the biggest and most irritating issue with Canvas. It works more reliable with static scenes but this is not the solution.


Same here, I had three kits, all three randomly show up as “not available” in HomeKit across all my iOS devices and automations keep failing. When switching to the Nanoleaf app I get a general communication error. I contacted support but just got the usual check your WiFi, reset, etc.

I have a dedicated 2.4GHz WiFi running for my IOT devices, everything like the Aurora, my vacuum robots, etc. work totally reliable. Just the canvas is giving me a hard time. Even the latest firmware 1.2 didn’t solve it.

Marre NL

There is a new firmware 1.2.1 just released today. Hope it can make difference. Just need some more time to test it.


Oh, actually the release notes specifically mention our problems. Please let us know, I took mine off and wanted to return them on Monday, but would be happy to keep them if the problem gets solved.

Marre NL

Good news, so far after latest firmware update 1.2.1 everything now is doing really well. I let you know if things changes

Marre NL

Yes, it is a beta. It is worth to wait for it. It works great, no more "no response" and scenes in automations changes really quickly. Still no issues for me after this update.


Just sent them a mail to get my controller registered for betas, glad to hear it works, sounds very promising.


Mine stop responding when I pair it with a shortcut. I thought it was because it wasn’t getting enough power but after reading this I’m thinking it’s not that.

Aliakbar Eski

hey @rough__waterfall__208

This thread and posts is about 5 years old. So any issues posted here are likely resolved.
I can help you with your issue however.
Can you elaborate on it?

Aliakbar Eski