Loosing wifi connection consistently.

Started by wheelhouse

wheelhouse

Nanoleaf panels are losing connectivity and becoming un-usable. I have complete hard and soft resets multiple times already and changed the Channel it operates on. It normally works for a few days or a week before it loses connectivity again. Currently I can’t even connect them to the app at all and get the below errors:

Serial numbers are: S16512A1094, S17512A1171 and S20442A0967

Failed is OSStatus code 3900 (kA11ParamErr)
Failed with OOStatus code 5 (EIO)

I have contacted support multiple times, completed all steps requested, confirmed my network is not the issue, tried a brand new controller sent from Nanoleaf and the problems still persist. I have had these for years and they worked without issue until a few months. Here are some additional steps I have taken;

Multiple hard and soft resets
tested with multiple controllers
confirmed on 2.4 wifi network
used ports 1,3,11 and others
confirmed app is updated
Tried the “RouteThisHelps” app per support which only provided vague info that support tried to say was causing my problem, To which I provided info proving support wrong.
And likely a few other things.

My support ticket is “139838” and it has been sent to the“R&D” team….

Anybody have suggestions?

Aliakbar Eski

Hey @wheelhouse

I reviewed the ticket that you have open with Nanoleaf Customer Support.
Would you happen to remember if the LED on your controller would begin to flash when the controller lost connection with your app? I am trying to isolate the issue, whether its between the controller and the WiFi router, or between the app and the controller (via the WiFi router, but there is no issue between the app and the WiFi router so that's ruled out).

If the LED did indeed flash, then the issue is the former that I mentioned, otherwise something in the latter.

Now, everything I mentioned would have been in the past, there is another issue that you are facing which is the issue with the iOS app. We are currently trying to resolve that with Apple since that error is thrown by the iOS system which we have no visibility over.
To unblock you in the interim, you can use the Nanoleaf desktop app (https://nanoleaf.me/en-CA/integration-hub/desktop-app/) which will allow you to provision the controllers to your network again and we can look at the LED as I mentioned above.

Edit: One potential workaround for the OSStatusCode5 issue is to restart the phone. Have you happened to have already tried that?

Hope this helps
Regards
Aliakbar Eski

wheelhouse

@"Aliakbar Eski"
I have no checked to see if the light flashes when it loses connectivity. Honestly, I don't know if I could actual pinpoint this because the lights will work for days/weeks and then just stop. I would have to stare at the device for weeks on end potentially to see if this occurs and unfortunately that is no realistic.

I have restarted my phone multiple times but that doesn't seem to resolve the setup issue consistently. I was able to complete the setup via Apple HomeKit once or twice when the setup wouldn't complete via the Nanoleaf app.

I will checkout the desktop app but that will solve the connectivity issues. If there are any other steps I can take to troubleshoot this please let me know! (I will keep an eye on the light on the controller when they lose connectivity and reply once I have some definitive info).

Aliakbar Eski

Hey @wheelhouse
If the LED is not doing anything, your controller is connected to the router and happy. At that point, any app that has been paired, should technically work (barring any other OS related issues).

In your normal course of usage, if you do come across connectivity issues, that is the time you look for the controller LED to be flashing. I hope this makes it easier for you to collect the data.

Restarting the phone has resolved this case in some cases and not all. It was a failed attempt. The Nanoleaf app and the Home App use the same pairing method that is Apple's HomeKit pairing. Its funny (and probably coincidental) that it worked from one app and not the other, but FWIW, it doesn't matter. Once paired with your home app, its also paired with your Nanoleaf app automatically.

If you do have it paired, and there is an upgrade waiting for the controller, go ahead and upgrade it. Apart from that, under your normal course of usage, if the controller does show unreachable in the app, let me know if the effect on the panels also seems frozen or not and if the controller's buttons work. Apart from that, at this point of time I don't want the troubleshooting to take up any more of your time.

Highly appreciative of your assistance in troubleshooting this issue.

Regards

wheelhouse

I'm paired on the computer and via my iphone 13 currently When it goes out I will come back and post an update.

wheelhouse

The lights are unreachable again. The module is not flashing. The error is pretty generic stating to make sure I'm connected to the wifi and that the nanoleaf is plugged in. No changes have been made what-so-ever.

Aliakbar Eski

@wheelhouse What Gary Funk asked and just to confirm once again, your panels are cycling colours normally and the buttons on the controller module work?

Regards

Gary Funk

I've had instances where my phone is unable to control a device and rebooting the phone lets it connect.

wheelhouse

@"Aliakbar Eski" @"Gary Funk" the device is "unreachable" in my nanoleaf app on my macbook air and also on my iphone. Rebooted my phone and this made no change. The exact error is "Device is unreachable. Please ensure it's powered on and your IOS device is connected to the same wifi network. Try turning your wifi on and off or power cycling your nanoleaf device." The nanoleaf has also been rebooted by unplugging it from power for 10ish hours and then plugging it back in.

I also rebooted the desktop app and it says it requires an update. But the update fails every time. It's stuck in some type of loop.

Honestly, it's not realistic to have to reboot all my devices in order to use the lights. At this point I'm back to these being completely useless again.

Aliakbar Eski

@wheelhouse for the desktop app there was an issue around updates. Please download the latest version from here

I want to debug this a bit more closely with you @wheelhouse so I will DM you.

Regards

Aliakbar Eski