firmware update 3.3.1 broke the controlers

Started by armandBLN
Cf861f267fcf6217a1fab51f173d2aca?s=128&d=mm

armandBLN

I have 2 nanoleaf lights systems with the music device.

After the update to 3.3.1 the devices stop working.

1 of them is not even able to join the app nanoleaf
2 one is able to join the nanoleaf app but get disconnected after one hour and i need you remove and add it again each time

I have now 2 desktop lights which are working just pushing the buttom.

BUT THE WORST is: the nanoleaf support is answer the same everytime i explain the issues

i wrote them 4 times "I did soft and hard reset" 100 times and the answer like robots: "please do a soft and hard reset"

Do you have robots supporting ?
Seriously your products are not cheap but you invest 0 in suuport.

I have 400 euros for nothing if the controler does not work

C39416f4bdabbd5010f596095fb24348?s=128&d=mm

Aliakbar Eski

Hi @armandBLN

We are really sorry for the inconvenience.
We are working on resolving this issue and will be issuing a firmware upgrade shortly which will solve the issue.

In the meantime, if you can DM me your serial number, we will be able to resolve your issue as well.

I checked in with my support team, and I believe they missed out on one important point. I am not sure if you have already done it, but please also remove the pairing from your iPhone after doing any kind of reset.
Since a reset only deletes the pairing on the controller and not the phone, you have to remove the pairing on the phone. Hopefully this will resolve your issue.

If you still lose connection within an hour, please tell me if the LED on the controller is flashing at a 4 second interval. This means the controller is losing connection with your network. That will be a separate issue and we will take a look into separately.

Thanks for being patient with us and helping us resolve the issue.

Regards

Cf861f267fcf6217a1fab51f173d2aca?s=128&d=mm

armandBLN

Hallo Eski

Of course I revome the pairing witt the iphone, there is no way to add a device if you dont remove the pairing with the app. I was writing for 4 days to the support team

Let me explain it again.

device one SN S18132A2023 got the update but after, one hour lost connection with the app. them you have to remove it (also unparing) and add it again, and works for 1-2 hours, next day is no longer working.

device 2 SN S18132A1831: no idea about the firmware status since the update starst this device is no longer availble for addint to the app, when you try to add it you get an error. Please see all the screenshots I sent to your support team

device 2 can not be updated again because can not be added to the app.

also I remove the devices from the cloud, I uninstall and install the app, I reboot the iphone everytime. also the router. but sorry is the firmware.

I have been updating the lights since 1 year no, (5 times at least) and always get stucked but with a soft reset or hard reset works. BUT NOT THIS TIME.

Seriusly your firmware has a bug and I have unusefull white decoration triangules.

I will be able to update device one as soon you launch a new firmware but not device 2.

Is there anyway to update the lights without connectig to the app?

05b38303adfdb6f8e59ea1a3a9edfbbe?s=128&d=mm

Sumocat

This has happened for me too. I have three connected Aurora setups and all three are incredibly unstable. One if completely unreachable via the App. The other two are intermittent at best. If a new firmware is coming, how do we update the panel controllers if they cannot be found on the network / app?

C39416f4bdabbd5010f596095fb24348?s=128&d=mm

Aliakbar Eski

Hey guys,

apologies for the delayed response.

@armandBLN
For device with SN S18132A2023, when it loses connection with the app, do the panels in anyway freeze? Are the controller buttons still responsive?

For device with SN S18132A1831, I understand that pairing has failed. And I also understand that a hard reset has not fixed it yet. I will check with CX team and take a look at the screenshots once again to get a refreshed understanding. A hard reset should have fixed it. If necessary, we will jump on a voice call and resolve this over phone.

@Sumocat
As long as the controller is not reset and still on the network we can force a firmware upgrade, with your permission of course.
If the controller has been hard reset, the specific issue that I have mentioned should have been resolved. If you are still facing issues then something else is not right.

If the controller has been soft reset, but you do not want to perform a hard reset so as to not lose your saved effects, you can use an android device to simply configure it on the network. If you don't have an android device available, you can use the Nanoleaf Desktop application to do the same (https://nanoleaf.me/en/consumer-led-lighting/products/smarter-series/nanoleaf-cloud/desktop-app/).
once the device is configured to the network, we can upgrade it, with your explicit permission as mentioned.
Just ensure that before you start the quick process of configuring the device to the network, a white LED on the controller must be on, indicating its ready to be configured

Regards
Aliakbar Eski

Cf861f267fcf6217a1fab51f173d2aca?s=128&d=mm

armandBLN

Hi Aliakbar

I really apreciate your support.

Regarding the first device, just loses connection, hardware buttons works.
Regarding the second device, hardware buttoms works for soft and hard reset but just for that.

Nanoleaf will send me two new controlers, so I cand send you back this wrong ones and you will be able to research with the develpers team about the issue.

Like you already know the firmeare update 3.3.1 includes some changes in de ID system paired of the devices, and could be the issue is coming from there and to be honest the new ios 13 has also a lot of bugs that do not help :).

C39416f4bdabbd5010f596095fb24348?s=128&d=mm

Aliakbar Eski

Hey @armandBLN

Glad to be of assistance.

For the first device, when it loses connection, does the led on the controller start flashing. That would indicate that the controller is losing connection with your wifi network, for some reason.

For the second device: do the panels just remain white or do they change color?
If they just remain white, then its a faulty controller for sure.

In anycase we released 3.3.3 today and your controller if its connected to the network, will automatically update to it. It might take a few hours for the update to take effect. But let me know if it does not.

Let me know when you get your hands on the new controller and if any issue still exists.

Regards

Cf861f267fcf6217a1fab51f173d2aca?s=128&d=mm

armandBLN

Hey Aliakbar

In the first device the issues is that works for a time (never more than one day) you add it and after hours or next day the app shows the device offline, so you have to remove it (do soft or hard reset) and add it again. So you are in a look where the device is offline every day and you have to remove it and add it everyday if you want to use the app.

I will try to update the device with the new firmware 3.3.3 this weekend in this device to let you know if the new firmware solve the problem.

For the second device the the leds remain white (but after a hard reset takes some colors settings from the controler and show colors) but there is no way to add it to the app, so there is no way to update the firmware.

If you show me another way to update this second device without the ios app I read there is a desktop app (you wrote to @Sumocat) I can also test it this weekend.

31162634171a0cfaf19a447a78c835e0?s=128&d=mm

Studio_2020

3.3.3 don't fix anything. My secound setup is also not working anymore.

Thanks Nanoleaf, for such a horrible experience.
I will remove my panels now and will search for an alternative.

Cf861f267fcf6217a1fab51f173d2aca?s=128&d=mm

armandBLN

Hi all

Firmware 3.3.3 fix the issue of one of my devices. The device is still online after one day.

Aliakbar just for your info, the update was done by the cloud without my intervention ( it tooks seconds ). So first device fixed right now.

Regarding the second device Im sure the firmware would fix it, but there is no way to add it to the app so I found no way to update it. If you show me a way to update it I could give you the feedback.

I would like in the future we are able to save all settins and ambients, with this issues I lost all settings and I have to program all again.

Cf861f267fcf6217a1fab51f173d2aca?s=128&d=mm

armandBLN

Hi Again

I have no idea why but the second device just get connected and updated.
both devices works no.

One of them was able to recover the seetings by the cloud but no the other one.
I have to create the ambients again for both togehter, but at least works.

Now the point is: the issues was solved by you in the cloud because I really did the same thing I was doing since the issue begins.

C39416f4bdabbd5010f596095fb24348?s=128&d=mm

Aliakbar Eski

Hi @armandBLN

The only thing the cloud probably did is upgrade your controller. Exactly how it managed to connect the network is concerning, even though it's a positive outcome.
In any case, we will keep a watch on the controller, and if you see any unexpected behaviour, please report it to me.

Regards
Aliakbar Eski