Can not add nanoleaf to Iphone app

Started by Askeptic
Ff9b75ff5e3f4b936c0b42b910ba4ea8?s=128&d=mm

Askeptic

My Nanoleaf panels was working great via the Nanoleaf IOS app. The power went out to the house one day, and when it came back on, the Nanoleaf was no longer responding to anything. From with in the app, it said it was unreachable. I can turn it on manually. I performed a hard reset of the panels and removed them from the app. When I go to set them back up, it initially locates them, and I scan the code that came in the box. The lights blink green a few seconds later and the app the remains "connecting" for an infinite amount of time. The panels are never added and the light on the control panel never goes out. I must reset the device to try again, however after 5 attempts, I still can not get the panels added to the app.

Any suggestions where to go from here?

  • Tried both a hard and soft reset
  • Tried unplugging and plugging back in
  • Tried resetting both home network devices and phone wifi

Thanks!

Ff9b75ff5e3f4b936c0b42b910ba4ea8?s=128&d=mm

Askeptic

Update - after ~10 hard resets / 5 hours of t-shooting, I was able to get them reconnected. Things I observed using network tools and sniffers….

1) The light panels would request DHCP and get an immediate response, but then take ~5 min to apply the address to its packets. This would cause the app to time out.
2) After it applies the address, I was able to re-add it through home kit, but the light panels now drop ~20% packets (ICMP test).
3) Light panel has 82% experience (good bidi wifi signal) and all other users moved to a different access point to ensure no congestion.

Seems that I have a bad controller with these panels.